2017-09-23 17:14 CEST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000205Cheat Enginepublic2013-01-24 01:14
Reportermgr_inz_Player 
Assigned ToDark Byte 
PrioritynormalSeveritymajorReproducibilityalways
StatusresolvedResolutionfixed 
Summary0000205: AOBSCAN(varname,bytestring) and varname+offset
DescriptionProblem with varname+offset.


This script doesn't pass "syntax check".
############
[ENABLE]
alloc(newmem,2048)
label(returnhere)
label(originalcode)
label(exit)
aobscan(ResetAmmoStorageUpgradesAOB,8B 87 0C 17 00 00 3B F0 7C 24 85)
label(codeResetAmmoStorageUpgrades)
registersymbol(codeResetAmmoStorageUpgrades)

newmem:
cmp esi,7
je originalcode
cmp esi,8
je originalcode

mov [eax+esi*4],0

originalcode:
mov eax,[eax+esi*4]
pop edi
pop esi

exit:
jmp returnhere

ResetAmmoStorageUpgradesAOB+34:
codeResetAmmoStorageUpgrades:
jmp newmem
returnhere:

[DISABLE]
codeResetAmmoStorageUpgrades:
db 8B 04 B0 5F 5E

dealloc(newmem)

unregistersymbol(codeResetAmmoStorageUpgrades)
##################


Gives error at line "ResetAmmoStorageUpgradesAOB+34:"
Additional InformationFrom rev. 1529("change aobscan to a label instead of a define") up to rev.1628
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0000443

Dark Byte (developer)

should be fixed now

~0000444

mgr_inz_Player (reporter)

aobscan(testing,FF FE BE EF)

gives:
"Error in line (...): This instruction can't be compiled"

~0000446

Dark Byte (developer)

Last edited: 2013-01-23 21:37

I can't reproduce this. It either returns "The array of byte named testing could not be found" or it just works

What is the code at the specified line number ? Or is the whole script just that line ?

~0000448

mgr_inz_Player (reporter)

Try the same script from "Description"

~0000449

Dark Byte (developer)

Last edited: 2013-01-23 23:25

Works as expected
"The array of byte named ResetAmmoStorageUpgradesAOB could not be found"
And if I change the aob to something that can be found, then it places a jump 0x34 bytes after it

edit: Nvm, I see what you mean when you do file assign to cheat table

~0000450

Dark Byte (developer)

Should be fixed now

~0000451

mgr_inz_Player (reporter)

One tiny tiny problem with "Execute" button.

Reproduce:
1) CE6.2+, without opened process
2) When I'm inside "Auto Assemble" window, NOT "Auto Assemble edit"
3) previous AA script used
4) After I click "Execute" I've got "Access violation"

CE6.2 just gives: "could not be found".

~0000452

Dark Byte (developer)

Scanerrors are now handled properly
+Notes

-Issue History
Date Modified Username Field Change
2013-01-14 16:34 mgr_inz_Player New Issue
2013-01-16 20:48 Dark Byte Status new => acknowledged
2013-01-23 04:54 Dark Byte Note Added: 0000443
2013-01-23 04:54 Dark Byte Status acknowledged => resolved
2013-01-23 04:54 Dark Byte Resolution open => fixed
2013-01-23 04:54 Dark Byte Assigned To => Dark Byte
2013-01-23 20:25 mgr_inz_Player Note Added: 0000444
2013-01-23 20:25 mgr_inz_Player Status resolved => feedback
2013-01-23 20:25 mgr_inz_Player Resolution fixed => reopened
2013-01-23 21:31 Dark Byte Note Added: 0000446
2013-01-23 21:31 Dark Byte Note Edited: 0000446
2013-01-23 21:37 Dark Byte Note Edited: 0000446
2013-01-23 22:57 mgr_inz_Player Note Added: 0000448
2013-01-23 23:24 Dark Byte Note Added: 0000449
2013-01-23 23:25 Dark Byte Note Edited: 0000449
2013-01-23 23:33 Dark Byte Note Added: 0000450
2013-01-23 23:33 Dark Byte Status feedback => resolved
2013-01-23 23:33 Dark Byte Resolution reopened => fixed
2013-01-23 23:51 mgr_inz_Player Note Added: 0000451
2013-01-23 23:51 mgr_inz_Player Status resolved => feedback
2013-01-23 23:51 mgr_inz_Player Resolution fixed => reopened
2013-01-24 01:14 Dark Byte Note Added: 0000452
2013-01-24 01:14 Dark Byte Status feedback => resolved
2013-01-24 01:14 Dark Byte Resolution reopened => fixed
+Issue History